Back to overview
Degraded

Whalesync performance is degraded

Jun 12 at 11:15am PDT
Affected services
app.whalesync.com
Data syncing

Resolved
Jun 12 at 12:59pm PDT

Whalesync services appear to be operating normally at this time.

We will continue to monitor upstream services to ensure we are not impacted.

Updated
Jun 12 at 12:00pm PDT

We have identified the core issue as a global outage with Google Cloud Platform:

https://status.cloud.google.com/incidents/ow5i3PPK96RduMcb1SsW

We have determined that the Data Syncing system is fully functional with some reduced performance.

Created
Jun 12 at 11:15am PDT

We are currently experiencing degraded performance affecting some Whalesynce users. Our team has identified that the issue is related to third-party services, including infrastructure provided by Google Cloud and authentication via Clerk.

We are actively working with these providers to resolve the problem as quickly as possible. We will continue to monitor the situation and provide updates here.

Thank you for your patience and understanding.