Back to overview
Degraded
Google Sheets Sync degraded
Apr 20, 2026 at 2:00pm UTC
Affected services
Data syncing
Resolved
Apr 20, 2026 at 3:11pm UTC
Our downstream provider has resolved their system issue. The "The custom code execution concurrency limit for your workspace" issues are no longer being generated for syncs using Google Sheets.
Affected services
Created
Apr 20, 2026 at 2:00pm UTC
We're currently seeing an increase in sync failures affecting the Google Sheets connector. The issue has been traced to a downstream provider, and we're actively working with them on a resolution. We'll post updates as we learn more. Thank you for your patience.
Affected services