Notion data source: incorrect delete operations synced during Notion incident
Resolved
Apr 21, 2026 at 11:24pm UTC
Syncing with Notion is restored. We're working with customers 1:1 who need to take manual action on their syncs. If you would like assistance, please reach out to support@whalesync.com and we'll be more than happy to help.
Affected services
Created
Apr 21, 2026 at 12:58pm UTC
Notion experienced an incident today where records were temporarily missing from their API responses (Notion status). Because these records appeared to have been deleted, Whalesync synced delete operations to connected destinations for affected users.
This impacts syncs where Notion is configured as a data source with sync deletes enabled. Notion is recovering and the missing records are returning, but we are currently assessing the full impact to affected users.
We will provide updates as we learn more.
Affected services