Back to overview
Degraded

Dashboard performance is slow

Feb 26 at 08:48am PST
Affected services
app.whalesync.com

Resolved
Feb 26 at 09:00am PST

We have identified the root cause of the issue as an extremely high volume of webhooks. We have moved all webhook handling to a separate service cluster and resolved the issue.

Created
Feb 26 at 08:48am PST

We have had reports that our dashboard is slow or fully unresponsive. We are actively investigating.